« Close

Datasheets and User Guides

App Notes

Software & Driver

 

LabJackDASY

DASYLab driver for the Windows UD library. The Windows UD library is the high-level Windows library/driver for the LabJack U3, U6 and UE9. For other LabJack devices, go to the Software page.

Please refer to the "Readme.txt" file in the zip for information regarding installation instructions and limitations.

The beta version should work with DASYLab 9+.

If you are using an older version of DASYLab use the DASYLab 7 & 8 download.

 

4 comments

I downloaded the driver and changed the .ini, but get the message LabJackdasy.dll could not be initialized.

 

You should first check and make sure the LabJackdasy.dll is in the right spot (with the Dasylab executable) or maybe try putting it in the system directory.  I would also make sure the normal LabJackUD insaller was used and you can run other applications that can use the LabJack, such as LJControlPanel.


Also, you should be able to use Modbus on most LabJack devices using Dasylab.

I tried loading this driver in DASYLab 10 and I never get anything in the log about loading the dll or even failure of loading it.  Verified it is in the right folder, tried many combinations under the extend portion of the ini file, just seems to not acknowledge it at all.

Also, the hope was to use this with the labjack T7, is that too much to ask?

Finally, I will try using modbus, but the goal is to be able to use the streaming function into dasylab.

The DASYLab drivers/modules on this page only support the UD driver and the LabJack U3, UE9 and U6. The LabJack T7 uses the LJM driver and would require a separate DASYLab module/driver which we currently don't provide. So at this time with the T7 you can only use direct Modbus TCP method, like with the UE9, in DASYLab unless you write your own module to the LJM driver. Unfortunately stream mode will not work with Modbus TCP.

As for getting one of these drivers on this page running, last time I tried the "Beta Release" it wasn't working in DASYLab 10 but the "Old version" did work. Also, first make sure our Windows drivers are installed beforehand:

http://labjack.com/support/software