Upgrade to Windows 10 failed | LabJack
 

Upgrade to Windows 10 failed

24 posts / 0 new
Last post
imac
Upgrade to Windows 10 failed

I upgraded from Windows 7 to Windows 10. Now the application has a run time error of access violation calling eGet(). I downloaded LabJack-2015-11-19.exe and installed it. I am VS 2012 and C# and recompiled the entire program. I did not change any of the code which was working before. What is the problem?

LabJack Support
LabJack Support's picture
If your eGet call is passing

If your eGet call is passing a pointer/array to the x1 parameter, please use the eGetPtr function instead with the same parameters. eGet is not 64-bit pointer safe (only the lower 32-bits of the pointer address value is passed), and can cause the "access violation errors" you are seeing in 64-bit applications and systems with over 4GB of RAM. eGetPtr is mentioned here in the documentation:

https://labjack.com/support/software/api/ud/function-reference/eget-and-...

Alternatively you can build your application to run as a 32-bit application only.

imac
I changed the call from eGet(

I changed the call from eGet() to eGetPrt(). I also installed version 3.47 of Labjack, I then also had to change the reference to the updated software. Then it worked.

BlueS
David Wehmeyer's picture
Hello, 

Hello, 

I have the same Problem for the eAIN Method. Is there a possibility to use easy functions and Build for x64?

I hope this is solved in one of the next releases. If it can't be solved I might need another way to read AIN Values.

Kind regards David

LabJack Support
LabJack Support's picture
We recently became aware of

We recently became aware of this eAIN bug and fixed it, but it currently isn't in a released or beta installer on the site. UD version 3.50 has the fix, and we will have a beta installer with this version soon. If you would like a copy of the driver now without an installer, email us [email protected] .

Alternative to using eAIN, you can use the AddRequest/Go/GetRequest method of reading analog inputs as demonstrated in the pseudocode:

U3: https://labjack.com/support/datasheets/u3/high-level-driver/example-pseudocode/analog-inputs
U6: https://labjack.com/support/datasheets/u6/high-level-driver/example-pseudocode/analog-inputs
UE9: https://labjack.com/support/datasheets/ue9/high-level-driver/example-pseudocode/analog-inputs

LabJack Support
LabJack Support's picture
The current Windows beta

The current Windows beta installer has UD v3.50 which fixes the eAIN bug.

Isabella
isabella's picture
I am also facing the same

I am also facing the same issues. I thought it was due to activation issues as I did not fully activate my windows 10. I am facing the same issues even after activating the OS with the help of [temporarily redacted by editor]. What might be the issue. Please help to fix it.

LabJack Support
LabJack Support's picture
Isabella, please explain what

Isabella, please explain what the error message or error code is and please explain what causes it to occur. Do either of the above solutions fix the issue?

AmyTran
amytran's picture
Hi,

Hi,

I install LabJack U6 driver (LabJack-2017-12-20.exe)  on my PC which has window 10. The installation is fine, but in the device manager it show LabJack U6 error ( with error code28) and it show Port_#0004.Hub_#0001.

Any ideas why it error on Window 10?

I able to get it work fine in Linux Ubuntu 16.04.

Thanks,

-Amy

LabJack Support
LabJack Support's picture
Error code 28 in device

Error code 28 in device manager is "Drivers for this device are not installed". The LabJack-2017-12-20.exe installer should install the device driver but there may have been an issue for some reason. Try the following.

1. Unplug your U6, then plug it back into a different USB port. If that doesn't help, try a Windows restart.

2. Unplug your U6. In File Explorer go to the "\Program Files (x86)\LabJack\Drivers\Install\LabJacka64" folder. Run dpinst64.exe and let us know if there are issues. This is the device driver installer which should have been ran by the LabJack-2017-12-20.exe installer. Note if using 32-bit Windows use dpinst32.exe from "\Program Files (x86)\LabJack\Drivers\Install\LabJackx86" instead.

Plug in your U6 and see if it still has the error in device manager.

3. In the device manager properties for the LabJack U6, use "Update Driver", browse to "\Program Files (x86)\LabJack\Drivers\Install\LabJacka64" folder and see if installs the device driver successfully. Browse to "\Program Files (x86)\LabJack\Drivers\Install\LabJackx86" instead if using 32-bit Windows.

Jtkeeper
Jtkeeper's picture
LabJack Support,

LabJack Support,

I am also having problems after moving to Windows 10. I have tried running all of your installers that state they support Windows 10. When I connect a USB to the computer, Device Manager still can not recognize the device. I have tried the above suggestion of going into the "\Program Files (x86)\LabJack\Drivers\Install\LabJacka64" folder and running the specific drive file. When I run it, it just states "Installation Failed".

Please help

Thank you!

LabJack Support
LabJack Support's picture
First quick things:

First quick things:

1.  Confirm the U6 & cable are fine with a different computer.

2.  Confirm that USB port is fine with a different device.

3.  Go to Windows Device Manager, find the entry that appears/disappears when you connect/disconnect the U6, right-click, select Uninstall device, let it uninstall, disconnect the U6, and reconnect the U6.

Jtkeeper
Jtkeeper's picture
I just realized this was on a

I just realized this was on a U6 forum. I have a T7 but I was just searching for any Windows 10 issue topic. I have still tried the suggestions in this thread.

1. The device was able to be discovered on a WIndows 7 machine

2. A mouse can be used from that USB port

3. I have attempted this and no change. The device still is unknown even after uninstalling the device and plugging it back in/reinstalling.

LabJack Support
LabJack Support's picture
1. Try rebooting the machine.

1. Try rebooting the machine.

2. Try re-downloading the installer, then reinstalling, then rebooting.

Please let us know if that doesn't work.

Jtkeeper
Jtkeeper's picture
Rebooting the machine and re

Rebooting the machine and re-downloading the installer and rebooting again was not successful.

Jtkeeper
Jtkeeper's picture
Device Manager now says

Device Manager now says "Labjack T7 Device" rather than "Unknown Device". There is still a yellow triangle next to it and when I look at the properties it still says no driver installed. So it oddly recognizes it as a Labjack, but still not installing the driver?

LabJack Support
LabJack Support's picture
1. What output does the

1. What output does the wizard give when you run: \Program Files (x86)\LabJack\Drivers\Install\LabJacka64\dpinst64.exe?

2. Does C:\Windows\System32 contain LabJackM.dll?

3. What are the recent relevant segments of output from (the bottom of) %WINDIR%\Inf\setupapi.dev.log? E.g. there should be at least one segment that looks like:

>>>  [SetupCopyOEMInf - C:\WINDOWS\System32\DriverStore\FileRepository\labjacka64.inf_amd64_f0c3eb76351e7796\labjacka64.inf]
>>>  Section start 2018/01/29 10:53:53.658
      cmd: "C:\Program Files (x86)\LabJack\Drivers\Install\LabJacka64\dpinst64.exe" /c /sa /f /lm /sw /PATH "C:\Program Files (x86)\LabJack\Drivers\Install\LabJacka64"
     inf: Copy style: 0x00000002
     inf: Driver Store Path: C:\WINDOWS\System32\DriverStore\FileRepository\labjacka64.inf_amd64_f0c3eb76351e7796\labjacka64.inf
     inf: Published Inf Path: C:\WINDOWS\INF\oem52.inf
<<<  Section end 2018/01/29 10:53:53.689
<<<  [Exit status: SUCCESS]

However, the Windows Setup log output for installing labjack64.inf could be in anywhere in %WINDIR%\Inf\Setupapi*.log.

Jtkeeper
Jtkeeper's picture
1. When I launch the driver

1. When I launch the driver executable, it attempts it for a split second and then the "Cannot Complete the Device Driver Installation Wizard" window pops up. Output is as follows:

Driver Name: LabJack Corp (WinUSB) LabJack USB (12/20/2017 2.4.0.0)

Status: Install Failed

 

2. Yes, LabJackM.dll is located there.

 

3.  

List of Errors found in setupapi.dev.log:

  1. 0x800b0109: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.
  2. Verifying file against specific Authenticode ( tm) catalog failed
  3. Driver package catalog file certificate does not belong to Trusted Root Certificates, and Code Integrity is enforced
  4. Driver package failed signature validation. Error = 0xE0000247
  5. Driver package failed signature verification. Error = 0xE0000247
  1. Failed to import driver package into Driver Store. Error = 0xE0000247
  1. Error 0x800b010a: A certificate chain could not be built to a trusted root authority.
  2. Error 0xe0000228: There are no compatible drivers for this device.
  3. Unable to select best compatible driver. Error = 0xe0000228
LabJack Support
LabJack Support's picture
Interesting! It looks like

Interesting! It looks like your root certificates are out of date.

1. Try updating Windows and reboot.

2. If that doesn't work, try making sure the date and time on your Windows machine is current.

Jtkeeper
Jtkeeper's picture
This is an offline system

This is an offline system that is not allowed to connect to the internet. Are there simple commands to get the updated root certificates/make sure time is synced? Is there a specific certificate I need to import for LabJack? Or is it a general 'get the latest Windows 10 root certificate' and import that?

LabJack Support
LabJack Support's picture
So far, it sounds like there

So far, it sounds like there are two things to try.

1. Disable Driver Signature Verification: boot into development mode or attach a debugger. Microsoft documents how to do this in the following link:

https://docs.microsoft.com/en-us/windows-hardware/drivers/install/installing-an-unsigned-driver-during-development-and-test

How-To Geek also has an article on this.

2. Update the root certificates somehow. Microsoft documents how to do this in the following link, though some of the links don't work and it might require a network connection (I haven't finished reading it):

https://support.microsoft.com/en-us/help/931125/how-to-get-a-root-certificate-update-for-windows

 

Please keep us appraised.

Jtkeeper
Jtkeeper's picture
Restarting the server and

Restarting the server and disabling the driver verification and then installing the driver fixed the problem! Thank you so much for your help!

knarf913
knarf913's picture
I am using Windows 10.

I am using Windows 10.

1) Python 2.7.16

2) Using a U3-LV

Python 2.7.16 (v2.7.16:413a49145e, Mar  4 2019, 01:37:19) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license()" for more information.
>>> import u3

Traceback (most recent call last):
  File "<pyshell#0>", line 1, in <module>
    import u3
ImportError: No module named u3
>>>

I installed the u3 the same way as linux except dropped sudo and get the above error.

Anyone have any idea whats wrong?

 

LabJack Support
LabJack Support's picture
That error usually indicates

That error usually indicates the LabJackPython modules were not installed, in this case for Python 2.7. If you have multiple versions of Python on your system, make sure you install LabJackPython modules (with its setup.py or through pip) to your 2.7.16 Python installation, or run the version of Python you installed LabJackPython to.

During the setup.py installation, check the folder where LabJackPython was copied/installed to for an indication on which Python version it was installed to. In general during installation, check for any error messages.