U3 in UART Mode at Baud Rate 115200 | LabJack

U3 in UART Mode at Baud Rate 115200

3 posts / 0 new
Last post
Shako's picture
U3 in UART Mode at Baud Rate 115200


I have the sample project for U3 UART that i built in CVI and i have been trying to communicate with a terminal program on the PC at the baud rate of 115200 but i see garbage when i sent data but i an receive data correctly at this baud rate.

I calculate the baud rate as follows. (65536-(48000000/(2*115200))) = 65327 

I'm using the latest labjack U3 hardware and the latest driver. I have attached my Sample CVI Project.

Any idea whats going on?

File Attachment: 
LabJack Support
labjack support's picture
We probably have a settings
  • We probably have a settings mismatch somewhere. Verify all the settings especially number of stop bits and number of data bits.
  • Have you tried a loop-back test on the U3?
  • Try slower speeds
  • Try tweaking the baud rate a little.

You may need to do a binary comparison between the data sent over the line and the data that is being reported. If the data looks right on the line then then problem is in the interpretation.

Shako's picture
OK so i found the problem.  I

OK so i found the problem.  I am using a RS232 TTL FTDI USB Cable to link the Labjack FIO4 (TX) and FIO5 (RX) to the PC so that i can see the data being sent. The highest baud rate that worked was 38400 but that wasn't enough for what i needed. After some troubleshooting I saw that the transmit voltage wasn't correct at 115200 and I placed a 4.6Kohms resistor between VS and FIO4 (TX) and that done the trick. 

I'm now communicating using the same source code that I attached previously with no problems.