setup.py not installing correctly? | LabJack
 

setup.py not installing correctly?

3 posts / 0 new
Last post
Sergej Grunevski
Sergej96's picture
setup.py not installing correctly?

I am trying to use labjack in Python 3.6; however, when I try to run the program, I either get the 'AttributeError: 'NoneType' object has no attribute 'LJUSB_OpenDevice'' (when I run it in PsychoPy) or 'dlopen(/usr/local/lib/liblabjackusb.dylib, 6): image not found' when I try to launch it from the terminal. I found that other users have had this problem, and I checked my permissions, installed using the latest GitHub clone...but the error persists. After a little digging in the site-packages folder and the /usr/local/lib, I found out that the liblabjackusb.dylib file is nowhere to be found, and that the site-packages folder only contains the LabJackPython-2.0.2-py3.6.egg file - nothing else!

At this point, I think that labjack is not installing properly - please advise. If that is not the case, please advise on the error messages above (I've gone through every forum post related to this issue). I am running macOS High Sierra (10.13.6).

LabJack Support
LabJack Support's picture
LabJackPython requires the

LabJackPython requires the Exodriver (the liblabjackusb.dylib USB driver) on macOS, which is not installed/included with LabJackPython packages. The easiest way to install the Exodriver on macOS is with its installer:

https://labjack.com/support/software/installers/exodriver

Under "Other Downloads and Resources" there is the Exodriver_NativeUSB_Setup.zip installer download.

Note that after running the installer, you should see the libusb-1.0 and liblabjackusb files in /usr/local/lib. If you have "dlopen(/usr/local/lib/liblabjackusb.dylib, 6)" related errors after running the installer and confirming files are in /usr/local/lib, then check directory and file permissions.

Sergej Grunevski
Sergej96's picture
Thanks! That fixed it :)

Thanks! That fixed it :)