Labjack u3 with max/msp 7 64 bit version | LabJack
 

Labjack u3 with max/msp 7 64 bit version

18 posts / 0 new
Last post
Mathias
mathias andersen's picture
Labjack u3 with max/msp 7 64 bit version

on your older forum i have seen a post about integrating labjack with max/msp. 

https://forums.labjack.com/index.php?showtopic=6229&page=2 

A 32bit external was created. Is it possible for you to create a 64bit version for max 7. 

it would be of incredible help to me. 

best regards, 

Mathias Andersen

LabJack Support
LabJack Support's picture
We can look into this soon.

We can look into this soon. Note that the download in the old forum topic has the source code if you want to recompile it for 64-bit now or add more functionality:

https://forums.labjack.com/index.php?showtopic=6229&p=20940

Mathias
mathias andersen's picture
Thank you very much. 

Thank you very much. 

i dont have the know how to recompile it myself. 

but if you get around to it, it would be amazing. 

LabJack Support
LabJack Support's picture
Attached has the 64-bit

Attached has the 64-bit external. Refer to the readme file for details. The 64-bit external was made with Max SDK 7.3.3, and tested with Max  7.3.4. Let me know if you run into issues with it.

Note that the provided external has simple functionality that the user in the old forum needed. It reads a specified number of analog inputs, single-ended. For more advanced functionality, you will need to write your own external and use our UD driver functions as demonstrated in the external source code.

Mathias
mathias andersen's picture
Hello, thank you so much.

Hello, thank you so much. Would it be possible for you to compile a OS X 64bit version as well. I need it for an art installation. 

I am am very impressed with your support. 

Best regards, Mathias Andersen. 

LabJack Support
LabJack Support's picture
Try the attached.  Note that

Try the attached.  Note that the code for the external had to be rewritten for Mac, but the patch is the same. Make sure to read the readme file for details. Let us know if you run into issues, but there may be some time before we can look into this again.

In case you run into these issues, here are some workarounds:

If you are getting no readings or -9999 readings, check the max console for messages.

If getting permission denied errors when opening the U3 in the max console, power cycle your U3. If you are getting couldn't read calibration errors, bang u3ReadsAINs a couple more times or power cycle the U3.

Snacks Daily
Snacks Daily's picture
Hey guys. Im running Max 6.1

Hey guys. Im running Max 6.1.10. Trying to run a Max patch. I am receiving an error that reads "u3ReadAINs: unable to load object bundle executable".  I have gone into file preferences and linked the folder that holds all the files. I downloaded the exodriver. I downloaded the max-sdk-7.3.3 folder and linked it in file preferences. No luck so far. Still receiving the same error.

LabJack Support
LabJack Support's picture
I see a "library not loaded"

I see a "library not loaded" error for Exodriver, liblabjackusb.dylib. Make sure you ran the Exodriver installer so that it is on your system. If that doesn't help, look at our response here regarding folder permissions for /usr/local/ and /usr/local/lib/ where where liblabjackusb and libusb-1.0 reside, and how to change folder permissions if they are not correct.

https://labjack.com/forums/u3/new-user-need-help-getting-started

 

Snacks Daily
Snacks Daily's picture
Thanks for the quick response

Thanks for the quick response. I had downloaded the Exodriver installer and installed the software the first time. I just did it again and I am experiencing the same problem. I am running macOS High Sierra 10.13.4.

 

I also went into terminal and double checked on the folder permissions. It looks like those are also as they should be?

 

Any other tips?

LabJack Support
LabJack Support's picture
Delete the u3ReadAINs.mxo you

Delete the u3ReadAINs.mxo you are currently using and use the one from the attached download. The 2017 download was built against a newer build of the Exodriver (2.6.0) than what is in the Exodriver Mac installer (2.5.2), and between those two versions there are no bug fixes or additional functionality added for the U3. I think this issue is a versioning conflict and the attached download has a u3ReadAINs.mxo built against Exodriver 2.5.2.

Let me know if the current build has issues, and provide the error messages if it does. If you want to test builds or modify functionality, which requires Xcode and the Max/MSP SDK, the source code for the external is in the download.

Snacks Daily
Snacks Daily's picture
Thank you for the help. I

Thank you for the help. I think that we have solved the issue. I have attached the current command + M list. 

 

Would you mind trying to explain what u3ReadAINs.mxo is, what it is doing, and why it seems to be working now?

LabJack Support
LabJack Support's picture
The u3ReadAINs.mxo is an

The u3ReadAINs.mxo is an external object which provides functionality between Max/MSP and our Exodriver library. Max/MSP cannot use our library direct, so an external is needed. It is written in C/C++.

Functionality wise, it reads AINs from the first found U3. The argument specifies the number of channels to read starting at AIN0, otherwise it defaults to 1 channel. It returns an output list of voltages for the specified number of channels.

The problem was a versioning conflict with the Exodriver. u3ReadAINs.mxo was trying to use a newer version of Exdriver than on your system. My previous post discusses it more.

Details on the contents of the download can be found in the readme.txt file.

Gusss
Gusss's picture
Hi

Hi

I've been using these since I originally requested them a few years ago without problems. However after a break I recently went back to using them. I'm still on Windows 10 64bit and still using max 6 both 64 and 32 bit. However I know get error code 126 in max. Amy idea why this is and what I can do?

LabJack Support
LabJack Support's picture
The UD driver does not have

The UD driver does not have an error code 126, but looking online it looks like in Max/MSP that error could indicate that a dll/external could not be loaded. Is there an error messaging to go with that error? Does it mention LabJackUD.dll?

If this is related to our dll, try reinstalling our Windows software to make sure LabJackUD.dll is installed on your system:

https://labjack.com/support/software/installers/ud

If related to the external, refer to the downloads readme.txt. Make sure the external file is in your Max/MSP's "File Preference" path and you are using the correct external for 32 or 64-bits.

Gusss
Gusss's picture
Ahhh I knew I'd forgotten

Ahhh I knew I'd forgotten something-I don't have your software installed on that laptop - it's been a while! That will be it. Thanks a million guys your customer service is just brilliant.

Paul Miller
lauprellim's picture
I'm having simliar problems

I'm having simliar problems to those described above.  Installed driver (version 2.5.2), external, set permissions correctly in /usr/local/lib, double checked all Max/MSP settings....still won't load.  Attached is a screen shot.

Strangely enough, it all works just fine on my 2013 MacBook.  The newer one running 10.14.6 is the one onewhich u3ReadAINs is not working.

LabJack Support
LabJack Support's picture
The error output indicates

The error output indicates there was an issue loading the Exodriver library. Please ensure you successfully download the Exodriver and verify your version of the library matches the max/msp external object "version" per the discussion above. You can verify the presence of the Exodriver library by running ls -la /usr/local/lib/liblabjackusb* in a terminal. That should display liblabjackusb.dylib and liblabjackusb<version>.dylib where <version> is the Exodriver version.

Paul Miller
lauprellim's picture
Thank you so much for

Thank you so much for checking my screenshot.

I was on Mac OS 10.14, and just upgraded to Catalina (10.15).  The external now works perfectly.

I'm very grateful that you made this external for Max/MSP!