T7 Stream - NO_RESPONSE_BYTES_RECEIVED | LabJack
 

T7 Stream - NO_RESPONSE_BYTES_RECEIVED

6 posts / 0 new
Last post
scott
scott1435145's picture
T7 Stream - NO_RESPONSE_BYTES_RECEIVED

Hi,

I have a T7-pro and I cannot seem to get stream mode to work.

I receive the error  NO_RESPONSE_BYTES_RECEIVED both in LJStreamM and using any of the stream functions in your MATLAB repository.

I can read analog inputs using the 'normal' mode via LJLogM, and they show up with expected values when connected in Kipling. I have loaded factory defaults, tried a variety of resolution indexes, settling times, send receive timeouts, and various other settings I've found on the forums to no avail. 

Any help would be greatly appreciated.

LabJack Support
LabJack Support's picture
What connection type are you

What connection type are you using? USB is the most reliable, so you probably should start by trying to get that to work.

Make sure you're running the latest software:

https://labjack.com/support/software/installers/ljm

Also, please update to the latest firmware using Kipling:

https://labjack.com/support/software/applications/t-series/kipling/devic...

If you reset to factory settings using SPC, then open LJStreamM and set it to stream AIN0, does it still happen?

If so, try disconnecting everything from the T7 except the USB and/or Ethernet cable. Does it still happen?

scott
scott1435145's picture
First of all, thank you for

First of all, thank you for the help.

This is using a USB connection.

I have had this issue on 3 computers, all running the last stable LJM release.

I did most of my playing around with firmware version 1.0287, but I have excactly the same issue on the latest firmware version 1.0292.

After the factory reset using SPC, it now works in LJStream!

However, still no success with the provided MATLAB script, but it's definitely an improvement.

LabJack Support
LabJack Support's picture
Is it giving the same NO

Is it giving the same NO_RESPONSE_BYTES_RECEIVED error if you run StreamBasic.m unaltered?

Make sure you're only using one program to talk to the T7 at a time.

Please try installing the latest beta software. LJM 1.2100 is more stable than LJM 1.2001.

scott
scott1435145's picture
I was running an untouched

I was running an untouched version of StreamBasic.m, and using only one program at a time.

I haven't installed the beta version at the moment, but it is working now.

As to the fix? Honestly, no idea. I've been playing around with it all morning, constantly getting the same error, started up a discussion with a colleague who had some ideas, and before I had changed anything it started working. I've run it dozens of times now, restarted, reconnected it and it keeps on working.

Ron.Gilliam
I am looking for someone to

I am looking for someone to assist with a project I have using T7 streaming several channels of data and generating operator interface to display various operator screens. If interested please contact [email protected]