T7 and MUX80 problem reading some addresses over modbus | LabJack
 

T7 and MUX80 problem reading some addresses over modbus

5 posts / 0 new
Last post
Robert
rbrtre's picture
T7 and MUX80 problem reading some addresses over modbus

Hi
I am using Labjack T7 with MUX80 board to read analog input values through modbus. I am reading one addness at the time and they work but I have no response at AIN66 which is modbus address 7132. If I look at Kipling Register marix, and set up RMS FLEX, Config A:20, Config D:1000 for all analog inputs, Kipling is reading AIN 65 just fine but AIN 66 causes error (2606). Please help.

LabJack Support
LabJack Support's picture
The RMS Flex feature uses

The RMS Flex feature uses stream mode internally, so consideration needs to be paid to your settings in regard to stream mode; Error 2606 indicates an invalid stream setting. Please try lowering the value of STREAM_RESOLUTION_INDEX (address 4010) to something below 8. If that is fine and you are still seeing issues ensure that your CONFIG_A, CONFIG_B, and CONFIG_D registers are set up correctly and that the settings are valid.

The RMS Flex feature page describes the stream limitation as well as a few other considerations:

https://labjack.com/support/datasheets/t-series/ain/extended-features/rms

Since you are constrained by stream mode limitations see table A.1.7 here:

https://labjack.com/support/datasheets/t-series/appendix-a-1

More information on our error codes can be found on this page:

https://labjack.com/support/software/api/ljm/error-codes

Robert
rbrtre's picture
Thanks for your reply. I just

Thanks for your reply. I just confirmed the settings and
STREAM_RESOLUTION_INDEX=1
EF_INDEX AIN0-3, 48-83=10
CONFIG_A AIN0-3, 48-83 =20
CONFIG_B This value is meaningless for RMS Flex so it is 0
CONFIG_D AIN 0-3, 48-83 = 1000
With these settings, going to Kipling Register matrix, selecting Anything between AIN0-3, 48-65 reads RMS value.
Selecting AIN84_EF_READ_A causes Errors
1. Ain Ef Channel Inactive (2583)
  - LJM Error Name: AIN_EF_CHANNEL_INACTIVE
  - Description: AIN_EF channel has not been initialized. To initialize, set the index to a non-zero value.
  - Operation: readMany 
  - Arguments: addresses: ["AIN0_EF_CONFIG_D","STREAM_RESOLUTION_INDEX","AIN0_EF_CONFIG_A","AIN1_EF_CONFIG_A","AIN3_EF_CONFIG_A","AIN2_EF_CONFIG_A","AIN1_EF_CONFIG_D","AIN2_EF_CONFIG_D","AIN3_EF_CONFIG_D","AIN48_EF_CONFIG_A","AIN49_EF_CONFIG_A","AIN50_EF_CONFIG_A","AIN51_EF_CONFIG_A","AIN52_EF_CONFIG_A","AIN53_EF_CONFIG_A","AIN54_EF_CONFIG_A","AIN55_EF_CONFIG_A","AIN56_EF_CONFIG_A","AIN57_EF_CONFIG_A","AIN58_EF_CONFIG_A","AIN59_EF_CONFIG_A","AIN60_EF_CONFIG_A","AIN61_EF_CONFIG_A","AIN62_EF_CONFIG_A","AIN63_EF_CONFIG_A","AIN64_EF_CONFIG_A","AIN65_EF_CONFIG_A","AIN66_EF_CONFIG_A","AIN67_EF_CONFIG_A","AIN68_EF_CONFIG_A","AIN69_EF_CONFIG_A","AIN70_EF_CONFIG_A","AIN72_EF_CONFIG_A","AIN71_EF_CONFIG_A","AIN73_EF_CONFIG_A","AIN74_EF_CONFIG_A","AIN75_EF_CONFIG_A","AIN76_EF_CONFIG_A","AIN77_EF_CONFIG_A","AIN78_EF_CONFIG_A","AIN79_EF_CONFIG_A","AIN80_EF_CONFIG_A","AIN81_EF_CONFIG_A","AIN82_EF_CONFIG_A","AIN83_EF_CONFIG_A","AIN48_EF_CONFIG_D","AIN49_EF_CONFIG_D","AIN50_EF_CONFIG_D","AIN51_EF_CONFIG_D","AIN52_EF_CONFIG_D","AIN53_EF_CONFIG_D","AIN54_EF_CONFIG_D","AIN55_EF_CONFIG_D","AIN56_EF_CONFIG_D","AIN57_EF_CONFIG_D","AIN58_EF_CONFIG_D","AIN59_EF_CONFIG_D","AIN60_EF_CONFIG_D","AIN61_EF_CONFIG_D","AIN62_EF_CONFIG_D","AIN63_EF_CONFIG_D","AIN64_EF_CONFIG_D","AIN65_EF_CONFIG_D","AIN66_EF_CONFIG_D","AIN68_EF_CONFIG_D","AIN67_EF_CONFIG_D","AIN69_EF_CONFIG_D","AIN70_EF_CONFIG_D","AIN71_EF_CONFIG_D","AIN72_EF_CONFIG_D","AIN73_EF_CONFIG_D","AIN74_EF_CONFIG_D","AIN75_EF_CONFIG_D","AIN76_EF_CONFIG_D","AIN77_EF_CONFIG_D","AIN78_EF_CONFIG_D","AIN79_EF_CONFIG_D","AIN80_EF_CONFIG_D","AIN81_EF_CONFIG_D","AIN82_EF_CONFIG_D","AIN83_EF_CONFIG_D","AIN0_EF_INDEX","AIN2_EF_INDEX","AIN1_EF_INDEX","AIN3_EF_INDEX","AIN48_EF_INDEX","AIN49_EF_INDEX","AIN50_EF_INDEX","AIN51_EF_INDEX","AIN52_EF_INDEX","AIN53_EF_INDEX","AIN54_EF_INDEX","AIN55_EF_INDEX","AIN56_EF_INDEX","AIN57_EF_INDEX","AIN58_EF_INDEX","AIN59_EF_INDEX","AIN60_EF_INDEX","AIN61_EF_INDEX","AIN62_EF_INDEX","AIN63_EF_INDEX","AIN64_EF_INDEX","AIN65_EF_INDEX","AIN66_EF_INDEX","AIN67_EF_INDEX","AIN68_EF_INDEX","AIN69_EF_INDEX","AIN70_EF_INDEX","AIN71_EF_INDEX","AIN72_EF_INDEX","AIN73_EF_INDEX","AIN74_EF_INDEX","AIN75_EF_INDEX","AIN76_EF_INDEX","AIN77_EF_INDEX","AIN78_EF_INDEX","AIN79_EF_INDEX","AIN80_EF_INDEX","AIN81_EF_INDEX","AIN82_EF_INDEX","AIN83_EF_INDEX","AIN83_EF_READ_A","AIN84_EF_READ_A"]

Robert
rbrtre's picture
Thanks for your reply. I just

Thanks for your reply. I just confirmed the settings and
STREAM_RESOLUTION_INDEX=1
EF_INDEX AIN0-3, 48-83=10
CONFIG_A AIN0-3, 48-83 =20
CONFIG_B This value is meaningless for RMS Flex so it is 0
CONFIG_D AIN 0-3, 48-83 = 1000
With these settings, going to Kipling Register matrix, selecting Anything between AIN0-3, 48-65 reads RMS value.
Selecting AIN84_EF_READ_A causes Error 2606

1Stream Config Invalid (2606)
  - LJM Error Name: STREAM_CONFIG_INVALID
  - Description: Stream resolution can not be greater than 8.
  - Operation: readMany 
  - Arguments: addresses: ["AIN0_EF_CONFIG_D","STREAM_RESOLUTION_INDEX","AIN0_EF_CONFIG_A","AIN1_EF_CONFIG_A","AIN3_EF_CONFIG_A","AIN2_EF_CONFIG_A","AIN1_EF_CONFIG_D","AIN2_EF_CONFIG_D","AIN3_EF_CONFIG_D","AIN48_EF_CONFIG_A","AIN49_EF_CONFIG_A","AIN50_EF_CONFIG_A","AIN51_EF_CONFIG_A","AIN52_EF_CONFIG_A","AIN53_EF_CONFIG_A","AIN54_EF_CONFIG_A","AIN55_EF_CONFIG_A","AIN56_EF_CONFIG_A","AIN57_EF_CONFIG_A","AIN58_EF_CONFIG_A","AIN59_EF_CONFIG_A","AIN60_EF_CONFIG_A","AIN61_EF_CONFIG_A","AIN62_EF_CONFIG_A","AIN63_EF_CONFIG_A","AIN64_EF_CONFIG_A","AIN65_EF_CONFIG_A","AIN66_EF_CONFIG_A","AIN67_EF_CONFIG_A","AIN68_EF_CONFIG_A","AIN69_EF_CONFIG_A","AIN70_EF_CONFIG_A","AIN72_EF_CONFIG_A","AIN71_EF_CONFIG_A","AIN73_EF_CONFIG_A","AIN74_EF_CONFIG_A","AIN75_EF_CONFIG_A","AIN76_EF_CONFIG_A","AIN77_EF_CONFIG_A","AIN78_EF_CONFIG_A","AIN79_EF_CONFIG_A","AIN80_EF_CONFIG_A","AIN81_EF_CONFIG_A","AIN82_EF_CONFIG_A","AIN83_EF_CONFIG_A","AIN48_EF_CONFIG_D","AIN49_EF_CONFIG_D","AIN50_EF_CONFIG_D","AIN51_EF_CONFIG_D","AIN52_EF_CONFIG_D","AIN53_EF_CONFIG_D","AIN54_EF_CONFIG_D","AIN55_EF_CONFIG_D","AIN56_EF_CONFIG_D","AIN57_EF_CONFIG_D","AIN58_EF_CONFIG_D","AIN59_EF_CONFIG_D","AIN60_EF_CONFIG_D","AIN61_EF_CONFIG_D","AIN62_EF_CONFIG_D","AIN63_EF_CONFIG_D","AIN64_EF_CONFIG_D","AIN65_EF_CONFIG_D","AIN66_EF_CONFIG_D","AIN68_EF_CONFIG_D","AIN67_EF_CONFIG_D","AIN69_EF_CONFIG_D","AIN70_EF_CONFIG_D","AIN71_EF_CONFIG_D","AIN72_EF_CONFIG_D","AIN73_EF_CONFIG_D","AIN74_EF_CONFIG_D","AIN75_EF_CONFIG_D","AIN76_EF_CONFIG_D","AIN77_EF_CONFIG_D","AIN78_EF_CONFIG_D","AIN79_EF_CONFIG_D","AIN80_EF_CONFIG_D","AIN81_EF_CONFIG_D","AIN82_EF_CONFIG_D","AIN83_EF_CONFIG_D","AIN65_EF_READ_A","AIN66_EF_READ_A","AIN0_EF_INDEX","AIN2_EF_INDEX","AIN1_EF_INDEX","AIN3_EF_INDEX","AIN48_EF_INDEX","AIN49_EF_INDEX","AIN50_EF_INDEX","AIN51_EF_INDEX","AIN52_EF_INDEX","AIN53_EF_INDEX","AIN54_EF_INDEX","AIN55_EF_INDEX","AIN56_EF_INDEX","AIN57_EF_INDEX","AIN58_EF_INDEX","AIN59_EF_INDEX","AIN60_EF_INDEX","AIN61_EF_INDEX","AIN62_EF_INDEX","AIN63_EF_INDEX","AIN64_EF_INDEX","AIN65_EF_INDEX","AIN66_EF_INDEX","AIN67_EF_INDEX","AIN68_EF_INDEX","AIN69_EF_INDEX","AIN70_EF_INDEX","AIN71_EF_INDEX","AIN72_EF_INDEX","AIN73_EF_INDEX","AIN74_EF_INDEX","AIN75_EF_INDEX","AIN76_EF_INDEX","AIN77_EF_INDEX","AIN78_EF_INDEX","AIN79_EF_INDEX","AIN80_EF_INDEX","AIN81_EF_INDEX","AIN82_EF_INDEX","AIN83_EF_INDEX","AIN64_EF_READ_A"]
 

LabJack Support
LabJack Support's picture
From your setup description

From your setup description it does not sound like you are configuring AIN84_EF_INDEX. You cannot read or write to the AIN84_EF registers if the index is not set to a feature, that is why we throw the AIN_EF_CHANNEL_INACTIVE error.