Sudden appearance of SYSTEM_MEMORY_BEREFT after 3 years of use | LabJack
 

Sudden appearance of SYSTEM_MEMORY_BEREFT after 3 years of use

4 posts / 0 new
Last post
fieryfire
fieryfire's picture
Sudden appearance of SYSTEM_MEMORY_BEREFT after 3 years of use

Dear Labjack,

 

We have been using the Labjack T7. And we use a lof of these systems on our project. But recently after 3 years of use, we suddenly get the error SYSTEM_MEMORY_BEREFT . The labjack that is being used itself is new and we have not once faced this situation before. Neither have we made any changes to our application software that uses the labjack. 

There is some information displayed here about this error. But what we don't understand is why the error appears suddenly when there has been no change in the application software.
https://labjack.com/support/datasheets/t-series/hardware-overview/ram

Also, could you give us a more detailed way to help correct this issue? Thank you very much

LabJack Support
LabJack Support's picture
The first step is to compare

The first step is to compare the firmware versions of the devices which work with the one that doesn't. There is probably slightly less RAM available on newer firmware versions.

If you find the units to have different firmware versions either downgrade the new unit to the firmware that works for you, or we need to look into reducing the memory requirements of your application. Forcing Lua to regularly collect garbage often helps.

fieryfire
fieryfire's picture
Thank you labjack. Would you

Thank you labjack. Would you know how much less RAM is available on the newer versions. we could adapt our software accordingly :)

LabJack Support
LabJack Support's picture
Unfortunately we don't. We

Unfortunately we don't. We don't have any tools to get information about the heap at this time.