Multi-T7 stream quadrature_New question | LabJack
 

Multi-T7 stream quadrature_New question

11 posts / 0 new
Last post
bianfenfa
cx's picture
Multi-T7 stream quadrature_New question

Hi All, gathering multiple encoder information in the stream mode.

With a channel list  defined like:

We're noticing that the values reported in "DIO2_EF_READ_A" AND "DIO6_EF_READ_A"are not what is expected.The latter two channels were greatly disturbed.Even without any instruments.

At this point, the data collected by the channel 1(The first encoder) is normal.

But in the channel 2(The second encoder).Even if the coder doesn't rotate,Still fluctuating

I don't know why.I need your help. Thank you.

File Attachment: 
LabJack Support
LabJack Support's picture
Please update to the latest

Please update to the latest software (2017-05-04) and firmware (1.0225) so you are running the same as us:

https://labjack.com/support/software/installers

If you are getting counts when you expect nothing, try jumpering those inputs to GND to see if you still get counts.  Or try jumpering all 6 FIO to GND.

How about connecting the same encoder to all 3 input pairs (FIO0/1, FIO2/3, and FIO6/7) to see if they all behave the same.

bianfenfa
cx's picture
1.Firstly, we use the latest

1.Firstly, we use the latest version the same as you are running.

2. By testing , connecting the same encoder to 2 input pairs  (FIO0/1, FIO2/3),you can see the result below. The lines were consistent, but many unknown disturbances were introduced.

3.But when using each channel separately, The result was normal.

I don't know why.

bianfenfa
cx's picture
I don't know whether it's my

I don't know whether it's my wiring problem or the equipment problem, I'd like to ask you to test it and give some reply. Thank you.

LabJack Support
LabJack Support's picture
I reproduced that strange

I reproduced that strange behavior. Firmware guys are looking at it now.

LabJack Support
LabJack Support's picture
I think we finally got this

I think we finally got this sorted out. Please try the new beta firmware 1.0228.

bianfenfa
cx's picture
Sorry to reply you so late.

Sorry to reply you so late. Some time ago on business trip. After downloading the latest version, I tested it again. Sorry to say, but the result is still unsatisfactory.

Of course, in your efforts, the result has been a good improvement. But there are still random disturbances. I don't know why. I hope you can help me test again. Thank you.

My encoder:2000 pulse/r     The speed is very low.

File Attachment: 
LabJack Support
LabJack Support's picture
A new firmware 1.0230

A new firmware 1.0230 addressed several issues related to stream and DIO_EF. Please try that version.

bianfenfa
cx's picture
In accordance with your

In accordance with your request, I tested the version 1.023 dual encoder synchronization acquisition effect. The results have been further improved, but still often interfere.
This may not be able to meet my experimental requirements, further industrial experiments are also difficult to carry out. I hope you can further improve the collection effect. Thank you.


 

 

LabJack Support
LabJack Support's picture
We managed to reproduce this

We managed to reproduce this error and have a couple ideas what may be causing it. With a little luck we will have this fixed soon.

LabJack Support
LabJack Support's picture
A couple issues have been

A couple issues have been fixed. Please try firmware version 1.0232.