T4 Ethernet 1298 Error | LabJack
 

T4 Ethernet 1298 Error

4 posts / 0 new
Last post
SKNO
sknowles.au's picture
T4 Ethernet 1298 Error

Hi All,

This is similar to the "T4 Isn't Recognisable" post.  I get the loading attributes error with Ethernet.

I have updated firmwave (1.0016) and even gone to Beta (1.0018), and used the 2018_08_30 and Beta2019_02_14 LJM downloads.

I have manually set the IP to 192.168.1.214 (T4 defualt I believe) using Kipling USB, and through Windows set the network DHCP off, and manually IPv4 address to the same.  I have even tried putting the above into ljm_specific_ips.config.

Critically a ping to the IP times out.  The TCPOpenTesting.vi fails for (A) - the above IP & port 502; and (B).

Kipling error:  "A device matching the requested device parameters was found, claimed, and connected, but a communication error prevented device attributes from being loaded to LJM. The device was not opened." as per previous post.

I have not tried using the SPC yet.

USB comm's are fine.  Thoughts anyone?

Thanks

SKNO
sknowles.au's picture
I have solved my issues.  The

I have solved my issues.  The Windows Local Area Connection needed the IPv4 IP address to be set (ie not automatically assigned), but in making it the same as the LJ an IP address clash was created.

I found this out as I had a second T4 to add to the system.  I set it up with latest Beta firmware, but gave it IP 192.168.1.215 (not .214), and it worked via ethernet immdeiately without changing anything. 

Setting the Windows LAC IPv4 address back to auto (from the 192.168.1.214 manually set before) broke the comm's on this new T4. I am settling with the LAC at .214, and the T4's at .215 and .216.

The first T4, which had never worked, was fine once Kipling was used to set its IP address to .216.  

LabJack Support
LabJack Support's picture
Using static IPs is a great

Using static IPs is a great idea, but you have to make sure every device on the network has a unique address ... the computer can't have the same address as the LabJack.

Before I assign a LabJack a static IP, I first do a Ping of that address from a computer to make sure nothing responds.

If there is an IT person in charge of the network, I asked them for a reserved static IP.

When I am in charge of a network myself and that network does use DHCP, I go to the router and limit he DHCP range to say .1 to .199.  Then I know that .200 to .255 can be used for static IPs and I keep a master Google Spreadsheet that lists what addresses are assigned to what devices.

 

SKNO
sknowles.au's picture
Thanks for the comment LJ

Thanks for the comment LJ Support.

I had pinged the IP address, and it was free when I set the T4.  The system did not work at this stage; the Windows Local Area Connection still had auto DHCPat this time.  I then tired setting the IP in Windows  - I thought I was pointing it to the T4 - but this did not work either. 

The next day I tried a second T4 but knowing the the .214 address was going to be used by the first T4, I indexed up one and gave this .215 atfer pinging.  The laptop (controller still set manually to .214) and this T4 now functioned immediately.  Reseting the Windows LOC to auto DHCP broke the system again.  As I mentioned above, I've settled on tle LOC at .214, the second T4 at .215 and the original T4 at .216

At least on this system, static IP's are required for the T4's and the Ethernet LOC on laptop (Realtek GBE controller).

Cheers