LJTick-DAC with T7 labview.

11 posts / 0 new
Last post
Rednecknerd
Rednecknerd's picture
LJTick-DAC with T7 labview.

I am currenty trying to get the LJTick-DAC to work with a T7 in labview. No success so far.

I created a small vi just to test without all the other stuff in my project.  I have the LJTick connected to FIO0 and FIO1

 

File Attachment: 
Rednecknerd
Rednecknerd's picture
Realized I had my control

Realized I had my control outside of the loop in the example.  Corrected that.

I am getting the tiny power up voltage on the proper channel. .037 VDC on my meter. No voltage on the other channel as expected.

Just can't control the voltage up.

File Attachment: 
LabJack Support
LabJack Support's picture
Since you have the tick

Since you have the tick connected to FIO0 & FIO1, you want to write TDAC0 and TDAC1 to update the output channels on the tick.

I don't see an obvious problem in your screenshot, but another way to quickly test is with the basic example "LJM_eReadName Example.vi".

Another way to test is with the Register Matrix in Kipling.

How do you know it is not working?  If you have it connected to some load disconnect that load.  Instead just jumper TDAC0 to AIN0 and read AIN0 to see the voltage.  Or securely clamp DMM probes in TDAC0 and GND.

 

Rednecknerd
Rednecknerd's picture
I am using a DMM on TDAC0 and

I am using a DMM on TDAC0 and GND.  I have completely removed the T7 from my test rig and am running it by itself.

No success with the "LJM_eReadName Example.vi"

the read example gave illigal address error.  But I assumed you meant write and tried that also.

"LJM_eWriteName Example.vi"

LabJack Error #2763:  TDAC_CAL_READ_FAILURE occurred at LJM_eWriteName.vi

So at least it is seeing it and just need to adjust code? 

Although from what I can see, the only progamatic difference from mine is the loop.

Rednecknerd
Rednecknerd's picture
Kipling failed to write to

Kipling failed to write to the register. So I moved it to FIO2 and 3.

Changed my TDAC to 2 and 3. Both kipling and my code work.

So I may have a problem with my T7 and FIO0 and 1.

LabJack Support
LabJack Support's picture
Try FIO0/1 again and make

Try FIO0/1 again and make sure all 4 pins are securely clamped.  Maybe one of them wound up under the clamp rather than in the clamp?

 

Rednecknerd
Rednecknerd's picture
I had that same thought. 

I had that same thought.  Still won't work on FIO0 and 1.

In my larger vi though I am using TDAC16 and 17 or CIO0 and 1.

They work in kipling now. But still having a problem with labview.

LabJack Support
LabJack Support's picture
So you can read TDAC16 in

So you can read TDAC16 in Kipling but not in LabVIEW?  What happens when you run LJM_eWriteName Example.vi?

 

Rednecknerd
Rednecknerd's picture
Got labview lined out.  It

Got labview lined out.  It was from not properly releasing the hardware from the programe.

Abinash
Abinash Tripathy's picture
Hello i want to interface a

Hello i want to interface a DSO with T7 pro by giving the analog out put to DSO.What are the pvi i can use from the T7 series..?

LabJack Support
LabJack Support's picture
So you want to control the

So you want to control the built-in DAC lines or LJTick-DAC with LabVIEW?  The following talks about different ways to control outputs:

https://labjack.com/support/app-notes/waveform-generation

... but if you are talking about the normal command-response updates you simply write to the "DACx" or "TDACx" registers.  See the following page, and in particular go through the 6 getting started steps:

https://labjack.com/support/software/examples/ljm/labview