Netbean9.0 and Java 10 compatibility?

4 posts / 0 new
Last post
brianT
btremaine's picture
Netbean9.0 and Java 10 compatibility?

I upgraded to Netbeans 9.0 since it was transferred to Apache from Oracle. Now Netbeans 9.0 is only compatible with Java 10 and forward. Will this work with the Labkack Java wrappers? 

LabJack Support
LabJack Support's picture
Our LJM and newer UD Java

Our LJM and newer UD Java wrapper should be compatible with Java 10, though we last tested with Java 8. If you find some Java 10 incompatibles let us know and we can look into it further. Note that LJM supports the LabJack T7 and T4, and the UD supports the LabJack U3, U6 and UE9.

As for our old UD wrapper and U12 wrapper which are JNI based, they will work with 32-bit Java only, and may work with Java 10. They are no longer updated, and provided as is.

brianT
btremaine's picture
I was having problems with

I was having problems with Netbeans 9/ Java 10 not recognizing or loading netbeans 8.2 projects. The netbeans 9 IDE did not even recognize an netbeans 8.2 project folder. 

Because of this I have changed back to netbeans 8.2 and Java 1.8.0_181.

Now the project build has errors with import com.labjack.labjackud.LJUD;  saying package does not exit.

I have attached a png file of my project folder layout.

 

 

 

File Attachment: 
LabJack Support
LabJack Support's picture
You are using the newer

You are using the newer wrapper from ljud.jar, which uses imports:

import com.labjack.LJUD;
import com.labjack.LJUDException;

The older wrapper LJUDJava.jar uses the import:

import com.labjack.labjackud.LJUD;

This call will fail when using ljud.jar since it is not available. Older code using LJUDJava.jar will need to be updated for the ljud.jar interface. Both interfaces are similar. Check one of the examples to see how your code will need to be updated (JNA data types are used, exceptions for errors, a constants class, etc.).