T7 on High Sierra | LabJack
 

T7 on High Sierra

3 posts / 0 new
Last post
Geoff
Geoff's picture
T7 on High Sierra

Hi,
Unfortunately, our IT group took my older Mac and gave me a new one with OS X 10.13.6 (High Sierra).  I can't get my Labjack T7 to connect to Kipling via the USB port or with Python.

Here are my installs
labjack_ljm_software_2018_10_30_beta
LJM Driver: 1.19
Kipling 3.1.14
OS X 10.13.6

When I first plug the LabJack in comm and status lights flash as expected then status stays on (green), comm turns off.  I believe this is normal.

Then I start Kipling, both LEDs flash quickly and stay on, however, Kipling still can't find the LabJack.

I also installed your Python modules from GitHub.  Here is the error the code throws when trying to connect.

Traceback (most recent call last):
  File "./lj.py", line 19, in <module>
    handle = connect_labjack()
  File "./lj.py", line 8, in connect_labjack
    handle = ljm.open(ljm.constants.dtANY, ljm.constants.ctANY, "ANY")
  File "/Users/hats/geoff/anaconda3/lib/python3.6/site-packages/labjack/ljm/ljm.py", line 370, in open
    raise LJMError(error)
labjack.ljm.ljm.LJMError: LJM library error code 1314 LJME_NO_DEVICES_FOUND
geoff$ open /Users/hats/geoff/anaconda3/lib/python3.6/site-packages/labjack/ljm/ljm.py

Any suggestions please?

 

LabJack Support
LabJack Support's picture
Please install the current

Please install the current non-beta version of the installer for now. Version labjack_ljm_software_2018_08_30.zip:

https://labjack.com/support/software/installers/ljm

Geoff
Geoff's picture
Yes, that solved my problem. 

Yes, that solved my problem.  Sorry, should have tried that originally.